Introduction


    WIN-911 Version 7 offers a direct connect with FactoryTalk HMI tags, where WIN-911's Scan & Alarm will connect directly to a FactoryTalk View SE Client on the same machine (note: this is for users with FT HMI tags, NOT an FT A&E Server). After completing the basic setup, and launching both your FactoryTalk SE Client and Scan & Alarm, if you are having problems seeing alarms, follow the troubleshooting guide below. In order to troubleshoot, you must first stop/close both WIN-911 and the FT client, this needs to be troubleshot one program at a time. The issue lies within one of the five issues listed below, and will need to be done in the ascending order, otherwise, you might miss the issue. 


    XML

    WIN-911 Bridge Service

    WBRSView

    Incorrect FT Area

    Command Line


    


    XML


        First thing you want to check is to make sure that your FT Client is launching the WIN-911 Bridge Service.  Launch your FT Client, and monitor the loading screen. At some point it is will say loading WIN-911 Bridge Service, as displayed below. If you see it, skip to WIN-911 Bridge Service section below.




If you do not see the FT Client attempting to launch, or you did not see the command to launch, you will need to run WIN-911's XML editor to insert that command into FT. Do so by navigating to the install folder, by default it is "C:\Program Files (x86)\Specter Instruments\WIN-911 V7\Tools"





Right-click the "XMLRSView.exe"and Run as administrator. Once it is a ran, you will see a black command prompt appear and disappear quickly. The machine will then have to be rebooted after.  





If you this is a networked application, and your alarm server and FT Client are on separate machines, copy that same .exe file, and run it on the alarm server machine. That machine will then have to be rebooted as well. Once the corresponding machines have been rebooted, relaunch the FT client, and check the loading screen once again. You should now see the Bridge Service launch, and you can continue troubleshooting


   


     WIN-911 Bridge Service


        If you are able to launch the client, and you see the "WIN-911 Bridge Service" launch from the load screen, shown below, it is important that you confirm that it is launched by running a Windows Task Manager. 




        In your Windows Task Manager, select "Processes"  and check the box to "Show processes from all users". (Note: If you are in Windows 2012 or newer, you will need to check under "Details"). Sort by "Image Name" and scroll down to the w's to find WIN-911 Bridge Service




If you see the that the WIN-911 Bridge Service is launched, you can scroll down to the "Scan & Alarm" section


If you still do not see the WIN-911 Bridge Service in the Task Manager, yet you see it loading the command in the FT Client, right-click on the FT client shortcut, under Compatibility, click on "Change settings for all users" which brings up another window, check the box that says "Run this program as an administrator" then try again, if successful launched, continue to the Incorrect Area section. 



In the event that the above settings is not available for your particular setup, you will have to take a different approach through a batch file.

    1)      open a new notepad file and use the text below:      
 
    start "" "C:\Users\Public\Documents\RSView Enterprise\SE\Client\<YOUR CLIENT FILE>.cli"


    2)      Save as NAME.bat (note: make sure the extension is ".bat" that will create the batch file)


    3)      Right click the batch file and select “Properties"

    4)      On the “Compatibility” tab click “Change settings for all users” near the bottom

    5)      Check the “Run as administrator” box, click “OK


    6)      Launch the batch file and re-check the Windows Task Manager


tip: If you want the client to startup on boot, create a shortcut to the batch file, then drop it in the startup folder.


tip: While you are trying to connect, it is always best practice to turn User Account Control off


    


    UAC


There are several instances where UAC prevents or slows down the transfer of data, it is recommended that you disable UAC. You can find this by simply entering in your search bar UAC to bring up User Account Control Settings.



Make sure that the slider is all the way at the bottom. (note: You may have to reboot after changing this setting).





    

    Scan & Alarm


At this point, the bridge service should be launched on the FT Client side, you can now check the WIN-911 side. First, open your WIN-911 Configurator, navigate to Tools>Diagnostic Logging> and check Data Source.



Save your changes, and right-click and run Scan & Alarm as administrator. With the Alarm Monitor open, select History, you will see 1 of 3 scenarios.



    1) With an failure dictating that there was an "Error instantiating WIN911BridgeService" continue on through to the WBSRSView section 



    2) If you are getting an AREA_DISCONNECTED error, skip to the Incorrect Area section. 




    3) In the event of a successful AREA_CONNECTED, but triggering of an alarm is successful in your FT HMI Alarm banner, but not in the WIN-911 Alarm monitor, skip to the Command Line section.



    
    WBSRSView


With the "Error instantiating WIN911BridgeService" logged, you now need to see if the Bridge Service is registered, you can do that by navigating to the install folder, by default it is "C:\Program Files (x86)\Specter Instruments\WIN-911 V7\Tools"





Right-click the "WBSRSView.exe"and Run as administrator. This will register the WIN-911 Bridge Service, and a dialog box like that below, will appear. 



The machine then needs to be re-booted. 


note: If the dialog box says that it has been UNregistered, then that same executable needs to be re-ran in order to re-register, then re-boot the machine


    1) In the event of a successful AREA_CONNECTED, but triggering of an alarm is successful in your FT HMI Alarm banner, but not in the WIN-911 Alarm Monitor, skip to the Command Line section.




    2) If you are getting an AREA_DISCONNECTED error, continue to the Incorrect Area section. 





    


    Incorrect Area


Since WIN-911 and the FT Client are launched on the same machine, Scan & Alarm needs to be pointed to the correct area in your project. By now, you should have confirmted the WIN-911 Bridge Service has been launched, but you are getting an AREA_ DISCONNECTED error in your Alarm Monitor. Open up your WIN-911 Configurator and navigate to the blue Data Source icon.



Double-Click on your RSView SE data source, which should open up your options, as seen in bottom-right image. Below is a side-by-side comparison of FactoryTalk Studio and your Data Source definition. Access Name is user defined. You will notice the the FT Area and what should be inserted in WIN-911. In the WIN-911, you will need a leading " " followed by the area name, in this instance, the area name is Waste Water (syntax is important, if there is a capital letter, use a capital letter), therefore in WIN-911, you will enter "/Waste Water". 


note: If this is a local application, you may not have an are, if so, you all you will need is a " "




Now that the changes are made, save and restart Scan & Alarm. With diagnostics still enabled, you will be able to see what/if any errors occurred. At this point, you should now see AREA_CONNECTED. Trigger an alarm and see if comes in, if it does not, and you see the AREA_CONNECTED, continue to the Command Line section 







    


    Command Line


With the FT Area connected, and no alarms coming in, navigate to FT Studio and open a command line. In the prompt, enter "alarmon" and hit enter. Then go back to WIN-911 and see if any alarms are coming through.



Conclusion

 

If you are still experiencing a problem, please submit Support Ticket or contact Product Support at 512-326-1011 x3 or toll free in the US and Canada at 1-800-331-8740 x3