Issue:
When trying to save Module Mapper you get a pop up error that states you are unable to save all endpoints. If the details mention the error is related to either
a) DataPortal.Update failed
b) ServiceInformationEditCollection.Child_Update method call
then you can follow the steps in this KB article to resolve the problem.
Example:
Cause:
This issue is most likely caused during an upgrade between WIN-911 versions and the SQL databases did not migrate properly. In order to correct the issue you will have to manually migrate the WIN-911 SQL databases.
Resolution:
Attached is a PowerShell script that will migrate the databases for you (WIN-911 2021 R1 to R4). If you do not want to use a powershell script, then follow the instructions below.
This will have to be run for each WIN-911 Module installed (data source + notifiers). Below are the commands to each module's path that must be typed (or pasted) into command prompt.
1. Open Command Prompt as Administrator.
2. Type or copy/paste below lines (1 at a time) into command prompt, then proceed to step 3.
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\ArchestrA"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\CIMPLICITY"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\Dispatcher"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\Email"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\FTAE"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\iFIX"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\InTouch"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\Mobile"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\Navigation"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\OpcDa"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\Opc"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\OpcUA"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\Reporting"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\SMS"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\Voice"
cd "C:\Program Files (x86)\WIN-911 Software\WIN-911\WebStudio"
3. Once you have changed your working directory in Command Prompt to one of the modules listed above, type or copy/paste the following command
Initializedatabase.exe migrate
4. You will not receive a success message. Command prompt will go to a new line entry if successful.
Repeat steps 2 and 3 for each installed data source and notifier module.
Example of steps 1-4:
You can verify the migrations were successful by looking at the %temp%/LogDatabaseInitializer.txt file.
You can now run WIN-911 Module Mapper and save properly.
Technical Support
To create a support case, you will need either your Customer Care Code or your Serial number. You can create a Case online or contact the product support line: (512) 326-1011.