Problem

When using V7 Pro I cannot hear anything when I get a callout through the TAPI modem. I am using Remote Desktop to access the WIN-911 application.



This error will occur in the Event Viewer logs:

AddTapi: 2018-12-14 09:03:39.64 Cannot obtain ID of wave/out device from call 10333 on line 'MultiMobile MT9234MU CDC-ACM-XR #3', TAPI error 80000042..
AddTapi: 2018-12-14 09:03:39.64 TapiException 80000048, Message='Could not obtain ID of wave/out device for line 'MultiMobile MT9234MU CDC-ACM-XR #3', Wave driver for this hardware is not installed or not configured properly.'
AddTapi: 2018-12-14 09:03:39.64 <MultiMobile MT9234MU CDC-ACM-XR #3> - Could not obtain ID of wave/out device for line 'MultiMobile
 MT9234MU CDC-ACM-XR #3', Wave driver for this hardware is not installed or not configured properly.



CAUSE

When making a call using TAPI, the system looks for the Hardware ID of the Wave Driver (Unimodem) when making a call, however, it won't find this file if you're using an RDP session. The default behavior when starting a RDP session is to bring the audio from the host to the RDP client, which breaks TAPI. To fix this issue, you need to change your RDP audio client settings to "Play on remote computer" under the Local Resources tab. Once you make this change, you'll need to reconnect to the WIN-911 system and stop the Telephony service and then restart the WIN-911 Voice Runtime (restarting the Voice Runtime will automatically restart the Telephony service).

 


Once you make this change, the audio should work.





PROCEDURE

Open up Remote Desktop Connection and click on Show Options 

 


Click on the Local Resources tab

 




Click on the Settings… button

 


Switch from “Play on this computer” to “Play on remote computer”

 




CONCLUSION

The error shows that TAPI is looking for something that is not there. What TAPI is looking for is the WAV files that is on the remote machine and not the local machine.